Вопрос перед закрытием УФ

&НаКлиенте
Перем ВыполняетсяЗакрытие;

&НаКлиенте
Процедура ПередЗакрытием(ОтказСтандартнаяОбработка)

Если Не Модифицированность Тогда
Возврат;
КонецЕсли;

Если Не ВыполняетсяЗакрытие Тогда
Отказ = Истина;
Показатьвопрос(Новый ОписаниеОповещения(«ПередЗакрытиемЗавершение»ЭтотОбъект), НСтр(«ru = ‘Данные изменены. Сохранить изменения?'»), РежимДиалогаВопрос.ДаНетОтмена);
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ПередЗакрытиемЗавершение(РезультатВопросаДополнительныеПараметры) Экспорт

Если РезультатВопроса КодВозвратаДиалога.Отмена Тогда
Возврат;
КонецЕсли;

Если РезультатВопроса КодВозвратаДиалога.Да Тогда
ИмяФайла Объект.ИмяФайла;
Если Не 
ДиалогСохраненияФайла(ИмяФайла) Тогда
Возврат;
КонецЕсли;
КонецЕсли;

ВыполняетсяЗакрытие = Истина;
Закрыть();

КонецПроцедуры

Добавить комментарий

Ваш e-mail не будет опубликован.

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.