ВыполнитьПаралельно

&НаСервере
Процедура ВыполнитьПаралельноНаСервере()

	МассивЗаданий = Новый Массив;
	Для Каждого ТекСтрока ИЗ ТЗСклады Цикл

		НаборПараметров = Новый Массив;
		НаборПараметров.Добавить("%ЗначениеПараметра1%");
		НаборПараметров.Добавить("%ЗначениеПараметраN%");

		// запуск фонового задания
		Задание = ФоновыеЗадания.Выполнить("%ОбщийСерверныйМодуль%.%Имяпроцедуры%", НаборПараметров);

		// добавляем задание в массив, что бы потом отследить выполнение
		МассивЗаданий.Добавить(Задание);
		
	КонецЦикла;

	// проверим результат выполнения фоновых заданий	
	Если МассивЗаданий.Количество() > 0 Тогда
		Попытка
			ФоновыеЗадания.ОжидатьЗавершения(МассивЗаданий);
		Исключение
			// действия в случае ошибки
		КонецПопытки;        
	КонецЕсли;
	
КонецПроцедуры // ВыполнитьПаралельно()

Добавить комментарий

Ваш e-mail не будет опубликован.

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.