Перевод числа из 10-й системы счисления

Функция ПереводЧислаИз_10_В_Любую(Знач Значение=0,Нотация=36) Экспорт
	
	Если Нотация <= 0 Тогда Возврат("") КонецЕсли;
	
	Значение = Число(Значение);
	
	Если Значение<=0 Тогда Возврат("0") КонецЕсли;
	
	Значение  = Цел(Значение);
	Результат = "";
	
	Пока Значение > 0 Цикл
		Результат = Сред("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ",Значение%Нотация+1,1)+Результат;
		Значение = Цел(Значение/Нотация) ;
	КонецЦикла;
	
	Возврат Результат;
	
КонецФункции

Добавить комментарий

Ваш e-mail не будет опубликован.

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.