Пустая дата в 1С

Источник: https://codernote.ru/1c/pustaya-data-v-1s/

Проверка на пустую дату в текстах модулей

Если Дата = '00010101' Тогда
//
КонецЕсли;

или
Если Дата = '00010101000000' Тогда
//
КонецЕсли;

или
Если Дата = '0001-01-01' Тогда
//
КонецЕсли;

или
Если Дата = Дата(1, 1, 1) Тогда
//
КонецЕсли;

Проверка на пустую дату в запросах
ВЫБРАТЬ
ЗаказПокупателя.Ссылка
ИЗ
Документ.ЗаказПокупателя КАК ЗаказПокупателя
ГДЕ
ЗаказПокупателя.Дата = ДАТАВРЕМЯ(1,1,1,0,0,0)

или
ВЫБРАТЬ
ЗаказПокупателя.Ссылка
ИЗ
Документ.ЗаказПокупателя КАК ЗаказПокупателя
ГДЕ
ЗаказПокупателя.Дата = &ПустаяДата;

Запрос.УстановитьПараметр("ПустаяДата",'00010101');

Добавить комментарий

Ваш e-mail не будет опубликован.

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.