Как определить что это табличная часть?

Функция ЭтоТипТабличнаяЧасть(Тип)

// 1- й вариант (не полный)
//Если Найти(Строка(Тип), "Документ табличная часть:") > 0 ИЛИ Найти(Строка(Тип), "Справочник табличная часть:") > 0 Тогда 
//  Возврат Истина;
//Иначе
//  Возврат Ложь;
//КонецЕсли;

ОбъектМетаданных = Метаданные.НайтиПоТипу(Тип);
Если ОбъектМетаданных = Неопределено ИЛИ ТипЗнч(ОбъектМетаданных.Родитель()) = Тип("ОбъектМетаданныхКонфигурация") Тогда 
    Возврат Ложь
Иначе
    Возврат ОбъектМетаданных.Родитель().ТабличныеЧасти.Найти(ОбъектМетаданных.Имя) <> Неопределено;
КонецЕсли;

КонецФункции // ЭтоТипТабличнаяЧасть()

Добавить комментарий

Ваш e-mail не будет опубликован.

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.