Сохранение_Восстановление настроек

// Процедура - Восстанавливает настройки из хранилища общих настроек
&НаСервере
Функция ВосстановитьНастройкиНаСервере()

    Перем
СохраненноеЗначение;

   
ключОбъекта      = "Обработка.ИмяОбработки";
   
ключНастроек     = "Обработка.ИмяОбработки.ИмяСохраняемогоПараметра";
   
описаниеНастроек = "Описание настройки";
   
имяПользователя  = ПользователиИнформационнойБазы.ТекущийПользователь().Имя;

   
ЗначениеНастроек = ХранилищеОбщихНастроек.Загрузить(ключОбъекта, ключНастроек, описаниеНастроек, имяПользователя);
    Если
ТипЗнч(ЗначениеНастроек) = Тип("Соответствие") Тогда
       
СохраненноеЗначение = ЗначениеНастроек.Получить("ИмяСохраняемогоПараметра");
    КонецЕсли;

    Возврат
СохраненноеЗначение

КонецФункции // ВосстановитьНастройкиНаСервере()

// Процедура - Сохраняет настройки в хранилище общих настроек
&НаСервере
Процедура СохранитьНастройки()

   
ключОбъекта      = "Обработка.ИмяОбработки";
   
ключНастроек     = "Обработка.ИмяОбработки.ИмяСохраняемогоПараметра";
   
описаниеНастроек = "Описание настройки";
   
имяПользователя  = ПользователиИнформационнойБазы.ТекущийПользователь().Имя;

   
настройки = Новый Соответствие;
   
настройки.Вставить("ИмяСохраняемогоПараметра", СохраняемоеЗначение);

   
ХранилищеОбщихНастроек.Сохранить(ключОбъекта, ключНастроек, настройки, описаниеНастроек, имяПользователя);

КонецПроцедуры
// СохранитьНастройки()

в Четверг сентября 17 от Администратор
Было ли это полезно?