Вопрос перед закрытием УФ

&НаКлиенте
Перем ВыполняетсяЗакрытие;

&НаКлиенте
Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)

    Если Не
Модифицированность Тогда
        Возврат;
    КонецЕсли;

    Если Не
ВыполняетсяЗакрытие Тогда
       
Отказ = Истина;
       
Показатьвопрос(Новый ОписаниеОповещения("ПередЗакрытиемЗавершение", ЭтотОбъект), НСтр("ru = 'Данные изменены. Сохранить изменения?'"), РежимДиалогаВопрос.ДаНетОтмена);
    КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ПередЗакрытиемЗавершение(РезультатВопроса, ДополнительныеПараметры) Экспорт

    Если
РезультатВопроса = КодВозвратаДиалога.Отмена Тогда
        Возврат;
    КонецЕсли;

    Если
РезультатВопроса = КодВозвратаДиалога.Да Тогда
       
ИмяФайла = Объект.ИмяФайла;
        Если Не
ДиалогСохраненияФайла(ИмяФайла) Тогда
            Возврат;
        КонецЕсли;
    КонецЕсли;

   
ВыполняетсяЗакрытие = Истина;
   
Закрыть();

КонецПроцедуры

в Четверг сентября 17 от Администратор
Было ли это полезно?